As an Amazon Associate we earn from qualifying purchases

Announcement

Collapse
No announcement yet.

My first flash!!

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    My first flash!!

    I was driving from Truro to Falmouth just after Christmas, doing 30mph on a level stretch of road, when I got my first angry flash from a young lad in a speedy car behind me. Either he was angry because he'd had rubbish Christmas presents from everyone or was irritated because I was driving slowly . Anyway, I pulled in when I could so he could overtake. I was doing 30mph simply because I just couldn't go any faster, in any gear. My Roma C15 is 14 years old and I find that when I set out on a drive it is very sluggish, sometimes it goes down to 20mph on a hill, but then on the way home from a 'day out' it seems to be ok. Is this normal? Does it just need a good talking to or should I get it checked out by my garage?

    Ta everyone, in advance of your advice!
    Sue

    #2
    Originally posted by Cornishsue View Post
    I was driving from Truro to Falmouth just after Christmas, doing 30mph on a level stretch of road, when I got my first angry flash from a young lad in a speedy car behind me. Either he was angry because he'd had rubbish Christmas presents from everyone or was irritated because I was driving slowly . Anyway, I pulled in when I could so he could overtake. I was doing 30mph simply because I just couldn't go any faster, in any gear. My Roma C15 is 14 years old and I find that when I set out on a drive it is very sluggish, sometimes it goes down to 20mph on a hill, but then on the way home from a 'day out' it seems to be ok. Is this normal? Does it just need a good talking to or should I get it checked out by my garage?

    Ta everyone, in advance of your advice!
    Sue
    No Sue,it is definately not normal,you should get 70-80 easily.C15`s are quick and gutsy.
    There was a thread on Ask Ant recently about exactly this problem and if I remember correctly Ant advised that the common cause was a stretched accelerator cable,it cured the problem for the individual concerned.
    Have a hunt for the thread or Ask Ant.
    Ian

    The thread is called slow going and the last entry was 3-11-2010 in Ask Ant
    I dont know how to transfer the thread to here,maybe graham or Pauline will help if they see this
    Last edited by Ian.C.S; 30-12-2010, 10:53.
    Young men sow wild oats.Old men grow sage.

    Comment


      #3
      This is the thread Ian mentioned
      Why not have a look at my latest wildlife photos, habitat projects and general natural world related shenanigans? https://facebook.com/Watsonswildlife

      Comment


        #4
        Gosh. My C15 has never gone above 50mph and I thought that was normal! The guy I bought it from told me that that was the speed he got out of it so although I have always been a bit embarrassed at the slowness I accepted it. Until I got flashed! The thought of my lovely Romahome being nippy is thrilling. I can't wait to see what happens when I go back to my garage. Thanks both of you for your help. Best New Year's present I could have!

        Comment


          #5
          Originally posted by glenw View Post
          This is the thread Ian mentioned
          thanks Glen! how do you do that please.
          Young men sow wild oats.Old men grow sage.

          Comment


            #6
            no problem!

            its easy when you know how!

            first, copy the address from the webpage you want to link to.

            then, when typing your reply, highlight the word you wish to become the link.

            then click the funny blue icon


            it will open a box. delete the http:// thats already in the box and then paste the address that you copied earlier, into the box.

            click ok


            job done!!
            Why not have a look at my latest wildlife photos, habitat projects and general natural world related shenanigans? https://facebook.com/Watsonswildlife

            Comment


              #7
              Hello,
              I hope you get it fixed soon. We had a similar problem with our C15 Hylo (1994) and took it to a local diesel garage. I'm not sure what he did, but he charged us £25 and it was like a rocket in comparison. I still think it was nippier than my Outlook is now!
              Aileen.

              Comment


                #8
                Thanks Aileen, I can't wait!

                Comment

                320x50 mobile only under posts reg users

                Collapse

                728x90 google ad under posts desktop only reg users

                Collapse
                Working...
                X