As an Amazon Associate we earn from qualifying purchases

Announcement

Collapse
No announcement yet.

Berwick with my Romini

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Berwick with my Romini

    Just returned from a few days near Berwick. The first official outing for my Romini. There was no ehu available so used the battery. The cooker was playing up(no grill and just one burner worked properly. But had a good time. Found a lot of people looking at my little van. Pam
    Last edited by pamsicle; 10-08-2010, 12:48.

    #2
    One burner and no grill sounds like hard work!

    It's probably just bunged up, so....

    Dismantle the top of the cooker (if it's like mine was, you need to undo screws with a phillips screwdriver) and give it a good clean and soak with bicarb.. poke through all the little pipes with a wire (curtain wire is good, don't force it anywhere though!) and you might find the nozzle bit on a hoover does a good job.

    Leave to dry, reassemble and then give it another whirl!

    Glad you enjoyed yourself in spite of the probs!

    Comment


      #3
      Romini cooker

      The burner and grill were checked at the caravan service. The left ring works perfect. The right lights up but if you try to turn it down it blows out. I was told that when they tried to correct this a screw they needed to get out had been snapped and they couldn't do anything about it. The grill worked fine as I checked it when I got it back from it's service. So I don't know what happened between the service and me going away. The gas bottle was low so I put on a new gas bottle which made no difference. In fact for some odd reason I lit the left hand burner and it lit ok but once switched off I couldn't relight it(most odd) then I put the nearly empty bottle on and it worked fine.Once it's stopped raining/thundering and lightening, I'll go and check it out and seeif I can sort the problem. Pam
      Last edited by pamsicle; 10-08-2010, 15:27. Reason: add to message

      Comment


        #4
        How strange is that, Pam?

        Re. the gas bottle thing, this points to a pressure switch problem, I would have thought. Perhaps the regulator needs replacing, it could be the prob is at the other end, where the gas feed comes in. If the pressure isn't right, or is fluctuating then you'll have probs such as those you describe.

        The cooker knobs are meant to be held in until the ring warms up, then you can let go and they stay lit - usually! Same with the grill. I still think that a good clean out might solve the problem as mine was doing a similar thing in my Roma and cleaning sorted it all out and it worked ok after that.

        Hope you can get it sorted!

        JayJay
        Last edited by jayjay; 11-08-2010, 09:39.

        Comment


          #5
          Sorry jayjay, but the Explorer hob needs lighting manually. The knobs will not push in (or at least are not meant to). Gas issues from the "rose" immediately.
          There is a gas manifold running across behind the knobs with a separate valve built in for each knob. Which can be detached and changed or cleaned. Turning the knob lets gas flow through a small jet, which is most likely partially blocked.
          Health and Safety were smaller issues when those hobs were made!
          By the way, I think many jet blockages are probably caused by leaving the system with bottles/regulators removed, and system open to allow dirt and possibly small insects to enter the pipe. Of course any foreign matter in the system will eventually block the jets.
          Jim.
          Last edited by Twolitre; 11-08-2010, 13:44.
          Keeping people waiting is stealing a part of their lives.

          Comment

          320x50 mobile only under posts reg users

          Collapse

          728x90 google ad under posts desktop only reg users

          Collapse
          Working...
          X