Announcement

Collapse
No announcement yet.

Heater problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Heater problem

    Romahome heater wont work. Propex 200. It has a red light flashing 3 times

    #2
    Can't help with your query I'm afraid Jeff+molly ,.

    Just wanted to say hello and welcome to the site.

    Hopefully, someone will be along to help

    Comment


      #3
      Have a look here. Saying low battery less than 10v, but it coud be bad earth or even try thicker wire, thin wire looses power over long lengths.
      http://www.vikingowners.org.uk/forum...4538&forumid=4

      Comment


        #4
        Have you been to Propex's own site and downloaded the manual?
        https://www.propexheatsource.co.uk/pdf/instructions

        Look at the fault table
        https://www.propexheatsource.co.uk/w...April-2018.pdf

        I think as jtr rhyl said you have low voltage. I believe one solution is to start the van so split charge is working and fire up the heater - once it is running switch off the engine - as said check your wiring connections there may be a volts drop across a dirty connection - or as I had this week a section of electric cable which is corroded. The solution replace the cable.
        Jon

        Comment


          #5
          Ive checked all conections and all seem ok . The reset button looks like it out but it dosent click back in so prob ok. Ill try it with the engine running to see if the voltage increase helps

          Comment


            #6
            If I was you, I would put a multi meter on joints, or put temp wire to the pos then neg side of the heater from battery, to see if the voltage has dropped, but starting engine is a brill idea. But on a lot of sites people complain about none start up faulty heater, most answers is thickness of wire and length of run.
            One on import diesel heaters say 25 amp wire for 2 meters then go to 6mm for longer runs.

            Comment


              #7
              I had a Propex in one of my vans that did that. Turned out the leisure battery had died. New battery sorted it.

              Comment


                #8
                I checked the battery and it was fine i also was adived to run the engine a try it. Still no joy

                Comment


                  #9
                  We had problems with our diesel Eberspacher heater until I uprated the thickness of the cables and made soldered joints. It works fine now.

                  Peter

                  Comment


                    #10
                    Condensation that forms inside the heater can be the cause of corrosion on the connectors that fit to the pcb in the heater. If the heater is blue you can gain access to the connections without the need to take the unit out and strip it, the orange heaters are a bit more of a fiddle.

                    Comment

                    Related Topics

                    Collapse

                    • djsooz
                      propex heating
                      by djsooz
                      Hi Ant, and the rest of you techie people,

                      I recently had to replace my leisure battery as it turned out it was kaput - thanks for previous...
                      22-10-2010, 23:17
                    • Grannyvan
                      Eberspacher again
                      by Grannyvan
                      I had the usual problem of apparently not enough battery oomph to start the Eberspacher water/space diesel heater in my Outlook. Lots of helpful advice...
                      30-05-2015, 17:52
                    • ahaeger
                      Erratic Propex Heater behavior
                      by ahaeger
                      Im hoping you might have some insight into my problem:

                      I have the Propex HS200 (bought within last 4 months) and I have been experiencing...
                      30-12-2018, 13:50
                    • peterholden
                      Eberspacher Heater
                      by peterholden
                      In the 11 years or so that we have had our Romahome we have never been entirely satisfied with the performance of the heater. Culminating in it refusing...
                      22-08-2018, 10:01
                    • Grannyvan
                      Eberspacher again
                      by Grannyvan
                      Hello Ant,

                      I had the apparently common problem of not enough battery oomph to start the Eberspacher water/space diesel heater in my Outlook....
                      01-06-2015, 21:33

                    320x50 mobile only under posts reg users

                    Collapse

                    728x90 google ad under posts desktop only reg users

                    Collapse
                    Working...
                    X