As an Amazon Associate we earn from qualifying purchases

Announcement

Collapse
No announcement yet.

Leisure battery and charging C15

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Leisure battery and charging C15

    Hi Ant,
    Am writing this from work so will be brief, on plugging C15 into the mains for first time, 240 socket, fridge worked and leisure battery started to charge.... After about 2/3 hours became aware on checking battery it was warm and the sound of bubbling from the cells, of course switched off and took out mains supply pronto...... The battery is I think 3yrs old and an 85amp and I supect is finished, as it hasn't held much of a charge 7.5vts (since I've had the van 2.5months) I have a 110 battery that I could try on the van.
    Before I do is it likely to be a 'charger' fault, anything I need to diagnose/do before trying 'new' battery... any advice welcome.
    Thanks very much
    Andyvan

    #2
    Hi Andy.
    It's most likely to be the battery, if there was a couple of cells shorting out in the battery ( caused by it freezing when flat in cold conditions), then it will get very hot while charging and the good cells would boil sooner. The Zig charger tends to whistle when its working too hard then cuts out on a thermal safety switch. I would try another battery known to be ok and see what happens before looking at blaming the charger.
    Ant

    Comment


      #3
      Thanks Ant,
      The zig didn't whistle, but the battery was definately warm/hot.... will now swap batteries.
      Cheers
      Andyvan

      Comment

      320x50 mobile only under posts reg users

      Collapse

      728x90 google ad under posts desktop only reg users

      Collapse
      Working...
      X