As an Amazon Associate we earn from qualifying purchases

Announcement

Collapse
No announcement yet.

eberspacher problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    eberspacher problem

    Hi Ant
    Ive searched many eberspacher threads but can find no specific reference to my problem where the green light on the programmer has stopped lighting up. Its a 99 reg Duo fairly new to me and Ive not had the heater running much and only for short periods to try it. Have I locked it out through ignorance? is it a fuse ? I also notice the fridge doesnt seem to work on 12v as fridge rocker switch doesnt illuminate when switched on.
    thanks--John

    #2
    Hi John.
    The Eberspacher control you'll have on your van does have a tendency to stick on the the on/off button, if you stab at the button you may find it works fine.
    The 12v fridge buttton will only light up while the engine is running and the dash board switch is on.
    Thanks
    Ant

    Comment


      #3
      eberspacher problem

      Thanks Ant---will try it out tomorrow--fingers crossed !
      John

      Comment


        #4
        eberspacher problem

        Hi Ant
        Got diesel in the tank and plugged into EHU and tried stabbing the on switch as you suggested (type 401) but no green light--so checked fuse in zig unit aux but no green light.
        The manual says check the main fuse for the heater--not sure where or what to try next.
        thanks ---John

        Comment


          #5
          John.
          The main fuse for the eberspacher for your age of vehicle is located under the passenger seat, there may be a 5amp fuse behind the zig panel, but this practice was fairly short lived.
          You could also check that there are no programs set on the control panel. I think your age of vehicle had the 7 day programmer, if any programs are set the on/off switch will not turn the heater on. You need to check that no programs are running, you should see a "P" with a line through it, then stab the button with three vertical wavey lines on it and set the dark thermostat bar to max using the triangluar up and down buttons.
          Apart from that it not easy to sort remotely and you may need to get someone to look at it for you.
          Thanks
          Ant

          Comment


            #6
            eberspacher problem --now joy

            Hi Ant
            I checked the fuses under the seat and they were both ok--but on returning to the control unit I noticed that the display was flashing--there was life so I quickly hooked up to mains, set the time and pressed on switch--green light and eventually heat.
            Its been on 20 mins or so now and its difficult to describe my joy--so many thanks Ant
            regards--John

            Comment


              #7
              eberspacher electrical problem

              John it seems you must have a dirty or oxidised contact on one of the fuses under the drivers seat as you disturbed them you improved the contact

              It would pay to remove the fuses and either clean or better still replace them with the same size fuse and give the fuse holder a squirt of WD 40 or similar switch cleaner a smear of Vaseline or petroleum jelly on the fuse blades would not go amiss as well

              Alf

              Comment


                #8
                eberspacher electrical problem

                Hi Alf
                Yes --thanks for the advice--I am steadily becoming familiar with how things work and where to look for troubleshooting with help from the forum.
                regards--John

                Comment

                320x50 mobile only under posts reg users

                Collapse

                728x90 google ad under posts desktop only reg users

                Collapse
                Working...
                X