As an Amazon Associate we earn from qualifying purchases

Announcement

Collapse
No announcement yet.

C15 starting issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    C15 starting issues

    Hi again Ant,
    It looks like a minor issue of mine has become rather major. My lovely van Gladys which you seemed to think was called Rory is currently unable to start about 50% of the time. When the starter enguages there is no issue but it sounds like it doesn't enguage at all, clicks when I try starting, then nothing happens. In the past i've just tried the ignition a couple more times and it's worked. Yesterday however, dropping off mother at the airport in the highly intimidating and secure heathrow drop off point she failed to start. Fortunately push starts work.

    What I'd like to know is:
    You pointed out a relay which might be the issue, how do I test to see if its the relay or the solenoid? Where is a good place to source the parts? I'd come down to you again but it's a 3 hour trek each way and knowing my luck i'd end up unable to start her stuck at a service station somewhere.

    -Adam

    Edit: Ah, found a similar thread after some more searching. I have a 1.7 non-turbo C15 1993. Just went out to see what the lights do on ignition but sods law had it that I couldn't recreate the problem. From memory there IS a clicking sound when the key is turned but the lights don't dim. Will try again tomorrow to be sure.
    Last edited by Sloeman; 23-06-2010, 21:58. Reason: Extra info

    #2
    Hi Adam.
    Most of the time it's the solenoid that gives trouble. You can buy a new ( exchange) starter complete from GSF, it can sometimes be cheaper to do that than pay someone to investigate the problem and then change the starter! The glow plug relay only gives trouble if it has corrosion on the terminals so you could check that first.
    If you're stuck and there are two of you, you can hold the key over in the start position while the other taps the solenoid with somthing solid but not too heavy, it will always go!
    Thanks
    Ant

    Comment


      #3
      I had a problem with intermitent poor starting power.
      I took off the starter motor washed the whole thing in degreaser, dismantled it, replaced brushes, re-faced ameteur end, re greased and re-assembled it.
      never causes any probs now.

      Next job head gasket needs doing, 5 hrs
      when will it ever end

      Comment


        #4
        Thanks both. After a lot of research I found a reconditioned starter for £40. My current one seems to be going through a phase of working on a semi-regular basis so i'll wait until a more convenient week to do the swap.

        Comment


          #5
          C15 starting issues

          I used to have the same problem with my C15 - but only in hot weather when the engine was hot. A new starter motor solved the problem.

          Comment

          320x50 mobile only under posts reg users

          Collapse

          728x90 google ad under posts desktop only reg users

          Collapse
          Working...
          X