As an Amazon Associate we earn from qualifying purchases

Announcement

Collapse
No announcement yet.

Battery Drainage

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Battery Drainage

    My leisure battery in my C15 seems to have drained the car battery.
    I think one battery is just connected directly to the other. Should there be some sort of intermediate connection to prevent this drainage.?
    Any ideas?

    #2
    I'm sure Ant will be able to comment better on the C15 - but no, they shouldn't be just connected together - for that very reason.

    The ZIG unit usually takes charge of vehicle / leisure batteries - if you haven't got one, then there should at least be a split-charge relay, which is designed to alternatly charge each battery - but seperate them with the engine off, so you don't drain the vehicle battery with leisure use.

    Mike

    Comment


      #3
      Jack.
      Mike has answered the question really, but the early C15s ( not sure how old yours is) came as very basic spec and often had retro fit bits fitted by either dealers or customers, many of these fits were a bit basic and I suspect someone has thought if they put two batteries in the van they would get away with never flattening the larger capacity. Sadly if one battery goes a bit sick ( as in your case) it will be constantly topped up by the other until eventually they are both flat. You need to have a relay fitted between the batteries switched by the alternator light feed from the back of the alternator. This only switches the relay once the red battery light on the dash has gone out therefor never having the batteries connected together until the engine is actually running.
      Ant

      Comment


        #4
        Just a thought but I have had this happen even with a relay fitted, the problem was the contacts on the relay had stuck in the closed position, giving rise to the same problem. Hope you get it sorted, there is nothing worse than a flat battery.

        Comment


          #5
          Originally posted by ant View Post
          This only switches the relay once the red battery light on the dash has gone out therefor never having the batteries connected together until the engine is actually running.
          Ant
          Hi Ant

          My relay is ignition controlled and not the correct way, and thought, as you discribe, this was the right way to do it, but thinking more about it I had the idea that when the battery light went out the wire would then be dead and so not energise the relay. As yet I havn't tried it, what am I thinking wrong?
          Regards Martin :thumbsup:

          Comment


            #6
            Hi Martin.
            The battery light wire becomes live once the light has gone out and the altenator is charging, so your logic actually is not the case.
            Thanks
            Ant

            Comment


              #7
              Thanks very much Ant, a rewire job then, when the weather get a bit warmer
              Regards Martin :thumbsup:

              Comment


                #8
                Hi Martin.

                It does take a bit of getting your head round how the alternator light works.

                Basically, one side of the lamp gets a positive from turning on the key - before you actually start the engine. The other side of the lamp connects to the aternator, as you know. Now, with the engine, and therefore the alternator, not turning, this wire is earthed through the alternator - therefore the lamp lights.

                When you start the engine, the alternator starts charging - and that wire that was earthed now receives a live feed from the alternator.

                As you know - a lamp needs a live AND an earth to operate - this one now has a positive feed on BOTH sides of it - so it goes out, as it's now lacking it's earth path.

                Hope this helps a bit.

                Mike

                Comment


                  #9
                  Earth and positive, earth then CHANGES to positive

                  Thanks very much for fixing my brain Mike, I now can fully understand how it all works, I just couldn't get my head round that one.

                  Nice and sunny here today, I might have a go at it later.

                  Thanks again
                  Regards Martin :thumbsup:

                  Comment


                    #10
                    All fixed,rewired and working OK

                    Thanks to everyone
                    Regards Martin :thumbsup:

                    Comment

                    320x50 mobile only under posts reg users

                    Collapse

                    728x90 google ad under posts desktop only reg users

                    Collapse
                    Working...
                    X