As an Amazon Associate we earn from qualifying purchases

Announcement

Collapse
No announcement yet.

I think it's bust

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I think it's bust

    Recently acquired Dimension, tried water heater, worked on gas but no go with leccy. Me, possibly naïve, green-as, thought it was as simpIe as plugging EHU into vehicle, turning on water heater at fused spur and away we go but nah! It didn't work, so started switching every other switch and permutations of switches in van but still nothing so I figure the heater's bust. It's a Mallaga 2E heater so is there a favourite? Is there a particular weakness to which these heaters are susceptible? It would be nice to be able to put my finger on something and fix it easily rather than take down to somewhere and have them fix it for a zillion quid.

    #2
    Welcome to the forum algerino . I don't know that camper or the water heater, but it has to have an electric immersion heater. If you can get the electrical connections cover off and put a voltmeter on the terminals of the heater element and see 230v when on EHU, and you are not getting hot water then it is indeed bust. You might be able to get a new heater element and fit it. Or possibly it has been plugged in and turned on when there wasn't any water in it, and a thermal trip might have tripped. These are typically a small red button on a small block of something. It may be that if you have one of these, just press the button - it may click and then the heater would work.
    Nil desperandum. In loco parenthesis: My old man's in inverted commas.

    Comment


      #3
      gasgas, thanks for your very swift reply. Erm, I'm OK with nuts and bolts and pipes and fittings and that but volts, amps, ohms resistances and all of that stuff just floors me. I'll give her another go; fill-up the water and once again, try everything, just to make sure and see if I can spot any red lights anywhere but I think it's gonna hafter be a "take it into somewhere" job and let then sort it out for ££££'s.

      Comment


        #4
        You have definately got mains power going through to the sockets etc? Because there is another fused spur above the battery box beside the rear passenger seat which is easy to miss.
        When you say switched on at fused spur you do mean the one at floor level under the fridge? I only ask because there were no labels on our fused spurs and what I thought was the fridge mains was in fact the water heater! Luckily, there was water in it when I made the mistake.(The spur next to the Zig panel is for the Fridge)

        Hope this helps, let us know how it goes.

        Steve

        Comment


          #5
          That was my first thought Lincoln57 . It is easy to miss that little switch near the floor. And of course the rocker, above the zig in ours, needs to be at electric.

          Comment


            #6
            Originally posted by Lucy's mum View Post
            That was my first thought Lincoln57 . It is easy to miss that little switch near the floor. And of course the rocker, above the zig in ours, needs to be at electric.
            My first thought too, so easy to miss that switch.

            If it’s working on gas then the heater is probably OK and it’s something that’s not turned on for the electric.

            as Lincoln57 says, do other things on electric work? and also check the fuse behind the wardrobe hasn’t tripped.
            ______________
            Guardian of the Ducks
            2 2 2 2 2 2 2 Quack!

            Comment


              #7
              Hello algerino you don’t say whether you have the instructions for the Malaga 2E, if not they are on the web at:
              https://propexheatsource.co.uk/wp-co...ns_issue_D.pdf

              I do think that, if you don’t want to pay £££ to fix a simple fault you should buy and use a simple multi meter use of which will give you some basic information required for fault finding, for example:

              Do you have 12V or less than 10V at the heater solenoid?
              Do you have AC mains at the heater?
              Is your immersion heater element open circuit, a short circuit or about 46 ohms resistance?
              The meter will also allow you to trace circuits which have concealed wiring.

              Do be very careful to avoid touching with your body parts wires with live mains potential. Before touching any wire or terminal etc check to see whether there is 12V or 230V AC present at that point.

              I hope that I have been able to post a .pdf of those Malaga 2E instructions. Good luck

              Malaga_II_Instructions_issue_D.pdf
              Attached Files

              Comment


                #8
                Just a quick word of warning here if you're going to start testing things yourself. The mains voltage testers you can get for seing if something is live (the type where you touch the wire with the tip of the screwdriver and the metal cap with your thumb) don't always work well in motorhomes (because of the earthing arrangements). Never assume that because the tester doesn't light up, the wire is dead - it could be the tester isn't working. Always test the tester first by touching something you know to be live and make sure it lights up. Hope this makes sense

                Comment


                  #9
                  Oh wow! what a wonderful response to my query. I thank all of you for taking the time to offer your help and advice. However, it's transpired that there is nothing wrong with the heater, it was me, the old duffer, that was at fault by not understanding how it works. It does seem to be a simple matter of plugging in the EHU and just turning on the heater's fused spur. I was also turning on another switch which is the indicator for the gas operation (red and green LED's). As many of you will know, when it goes from the green LED back to the red one, the heater not functioning............. but I've now found out that that's only for the gas side of the job and nothing to do with the leccy. So! this morning after getting fed-up with it I went and did other things and left everything turned on in the van. Returning later I turned on the hot tap and believe me, the water was scalding hot. So there we are then, all's well.
                  Once more, thanks for the help, yours truly Algerino, fully fledged dum-dum.

                  Comment

                  320x50 mobile only under posts reg users

                  Collapse

                  728x90 google ad under posts desktop only reg users

                  Collapse
                  Working...
                  X